No Image

Cisco коммутатор 3 уровня настройка

СОДЕРЖАНИЕ
3 065 просмотров
10 марта 2020

Как настроить коммутаторы cisco 3 уровня, на примере cisco 3560

Как настроить коммутаторы cisco 3 уровня, на примере cisco 3560

настроить cisco 3560

Всем привет, сегодня хочу рассмотреть вопрос, о том как настроить коммутаторы cisco 3 уровня модели OSI, на примере cisco 3560. Напомню, что коммутаторы cisco 3 уровня не используются для выхода в интернет в качестве шлюза, а только маршрутизируют трафик между vlan в локальной сети. Для выхода в интернет cisco как и все вендоры предоставляет маршрутизатор? ниже представлена самая распространенная схема подключения.

Оборудование и схема сети

Предположим, что у меня коммутатор 3 уровня cisco 3560 24 порта, он выглядит как то вот так.

Он будет маршрутизировать трафик между vlan в моей локальной сети, и к нему допустим будут подключены 3 коммутатора 2 уровня модели OSI, уровня доступа, коммутаторы cisco 2960, а сам cisco 3560 будет выступать в качестве коммутатора уровня распределения. Напомню, что на втором уровне коммутируется трафик на основе mac адресов. Уровень доступа это куда подключаются конечные устройства, в нашем случае компьютеры, сервера или принтеры.. Ниже схема.

Что такое коммутатор второго уровня

Коммутатор второго уровня это железка работающая на втором уровне сетевой модели OSI

  • Коммутирует трафик на основе мак адресов
  • Используется в качестве уровня доступа
  • Служит для первичного сегментирования локальных сетей
  • Самая маленькая стоимость за порт/пользователь

В технической документации коммутатор второго уровня обозначает в виде вот такого значка

Что такое коммутатор третьего уровня

Коммутатор третьего уровня это железка работающая на третьем уровне модели OSI умеющая:

  • IP маршрутизация
  • Агрегирование коммутаторов уровня доступа
  • Использование в качестве коммутаторов уровня распределения
  • Высокая производительность

В технической документации коммутатор третьего уровня обозначает в виде вот такого значка

Помогать мне будет в создании тестового стенда программа симулятор сети, Cisco packet tracer 6.2. Скачать Cisco packet tracer 6.2, можно тут. Вот более детальная схема моего тестового полигона. В качестве ядра у меня cisco catalyst 3560, на нем два vlan: 2 и 3, со статическими ip адресами VLAN2 192.168.1.251 и VLAN3 192.168.2.251. Ниже два коммутатора уровня доступа, используются для организации VLAN и как аплинки. В локальной сети есть 4 компьютера, по два в каждом vlan. Нужно чтобы компьютер PC3 из vlan2 мог пинговать компьютер PC5 из vlan3.

С целью мы определились можно приступать. Напоминать, про то что такое vlan я не буду можете почитать тут.

Настройка cisco коммутатора 2 уровня

Настройка коммутатора второго уровня очень простая. Начнем настройку cisco catalyst 2960, как вы видите у меня компьютеры PC03 и PC04 подключены к Switch0, портам fa0/1 и fa0/2. По плану наш Switch0 должен иметь два vlan. Приступим к их созданию. Переходим в привилегированный режим и вводим команду

теперь в режим конфигурации

Создаем VLAN2 и VLAN3. Для этого пишем команду

задаем имя пусть так и будет VLAN2

Выходим из него

Аналогичным образом создаем VLAN3.

Теперь добавим интерфейс fa0/1 в vlan 2, а интерфейс fa0/2 в vlan 3. Пишем команду.

Говорим что порт будет работать в режиме доступа

switchport mode access

закидываем его в VLAN2

switchport access vlan 2

Теперь добавим fa0/2 в vlan 3.

switchport mode access

switchport access vlan 3

Теперь сохраним это все в памяти коммутатора командой

Настроим теперь trunk порт. В качестве trunk порта у меня будет гигабитный порт gig 0/1. Вводим команду для настройки порта gig 0/1.

Сделаем его режим trunk

И разрешим через транк нужные вланы

Сохраняем настройки. Все настройка коммутатора второго уровня почти закончена.

Теперь таким же методом настраивает коммутатор Switch1 и компьютеры PC5 в VLAN2 и PC6 в VLAN3. Все на втором уровне модели OSI мы закончили, переходим к 3 уровню.

Настройка cisco 3560

Настройка cisco 3560, будет производится следующим образом. так как наше ядро должно маршрутизировать внутренний локальный трафик, то мы должны создать такие же vlan, задать им ip адреса, так как они будут выступать в роли шлюзов по умолчанию, а так же trunk порты.

Начнем с транк портов, у нас это gig 0/1 и gig 0/2.

заходим в настройку интерфейса gig 0/1 и gig 0/2

int range gig 0/1-2

Попытаемся включить режим транка

switchport mode trunk

но в итоге вы получите вот такую подсказку: Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. Смысл ее в том, что вам сначала предлагают включить инкапсуляцию пакетов. Давайте настроим инкапсуляцию на cisco 3560.

Читайте также:  Darksiders warmastered edition секреты

Теперь укажем режим и разрешенные vlan

switchport mode trunk

switchport trunk allowed vlan 2,3

Сохраним настройки Cisco

Далее создадим vlan и назначим им ip адреса, которые будут выступать в роли шлюзов.

Назначим ip адреса для каждого из них, напомню для vlan 2 это 192.168.1.251/24, а для vlan 3 192.168.2.251/24

ip address 192.168.1.251 255.255.255.0

ip address 192.168.2.251 255.255.255.0

Теперь включим маршрутизацию между vlan, делается это командой

Проверка доступности

Открываем командную строку на PC3 и пробуем пропинговать его самого, шлюз и PC5. Вводим по очереди

Видим, что все отлично пингуется, значит связь есть.

Проверим теперь с PC3 соседа из VLAN3 PC6

Как видим, первый запрос потерялся, это происходит по тому, что перестроилась arp таблица, а дальше видим пакеты доходят до адресата.

Как видите настройка коммутатора второго уровня и третьего закончена. Задача выполнена. Вот как можно использовать коммутаторы cisco 3 уровня, и создать отличное ядро локальной сети. Если у вас есть вопросы и пожелания пишите в комментариях.

Read this article in English

Рассмотрим случай, когда требуется подключить несколько отделов фирмы в разные логические сети Vlan и обеспечить их связность, используя один коммутатор 3 уровня Cisco 3560. Все команды будут актуальны также для модели Cisco 3850 и для других коммутаторов Cisco.

Требуется организовать следующие сети (Vlan):

— Сеть отдела продаж ( 192.168.10.0 255.255.255.0)
— Сеть бухгалтерии ( 192.168.20.0 255.255.255.0)
— Сеть администраторов ( 192.168.100.0 255.255.255.0)
— Сеть для управления сетевым оборудованием ( 192.168.1.0 255.255.255.0)

Важно!
Устройства 2го уровня способны передавать данные только внутри одной сети и осуществляют передачу на основе информации о MAC адресах. Устройства 3го уровня используются для передачи данных между различными сетями и руководствуются информацией об ip адресах.

Коммутатор 3его уровня (Например Cisco 3560 или Cisco 3850) представляет собой совмещенные в одном устройстве коммутатор 2ого уровня модели OSI (или уровня доступа) и маршрутизатор (устройство 3го уровня).

Важно!
Один коммутатор Cisco 3560 фактически заменяет собой связку коммутатора Cisco 2960 и маршрутизатора Cisco 2811. Однако использовать такой коммутатор для внешних соединений крайне не рекомендуется. Интернет и любые внешние каналы следует подключать вначале к отдельному маршрутизатору или межсетевому экрану, а коммутаторы 3го уровня использовать только для организации внутренней сети.

(Решение аналогичной задачи организации нескольких Vlan на коммутаторе уровня доступа Cisco 2960 (2го уровня) и маршрутизатора Cisco 2811 рассмотрено в этой статье)

Шаг 0. Очистка конфигурации

(Выполняется только с новым или тестовым оборудованием, так как ведет к полному удалению существующей конфигурации)

После извлечения коммутатора из коробки, подключаемся к нему с помощью консольного кабеля и очищаем текущую конфигурацию, зайдя в привилегированный режим и выполнив команду write erase. (Подробнее о режимах конфигурирования оборудования Cisco можно прочитать в этой статье)
Switch > enable
Switch# write erase
/подтверждение очистки конфигурации/
Switch# reload
/подтверждение перезагрузки/

После выполнения коммутатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале базовой настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no

Шаг 1. Имя устройства

Присвоим коммутатору имя SWR-DELTACONFIG-1. (SWR – сокращение названия SWitch Router) Для этого зайдем в режим конфигурирования(conf t) и введем следующие команды:
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# hostname SWR-DELTACONFIG-1
SWR-DELTACONFIG-1 (config)#

Название устройства изменится со «Switch» на заданное значение.

Шаг 2. Интерфейс для удаленного управления

Для удаленного управления устройством зададим ip адрес на интерфейсе Vlan 1. После не забудьте включить его командой no shutdown
SWR-DELTACONFIG-1(config)#
interface vlan 1
ip address 192.168.1.1 255.255.255.0
no shutdown

Шаг 3. Авторизация пользователей

Настраиваем авторизацию для доступа к коммутатору. Для этого:

  • Задаем пароль доступа к привилегированному режиму (знак # рядом с названием устройства) командой enable secret
  • Создаем учетную запись пользователя и пароль для удаленного подключения командой username … secret …

SWR-DELTACONFIG-1(config)#
enable secret *****
username admin secret *****

Включаем авторизацию, с использованием локальной базы данных пользователей и паролей
SWR-DELTACONFIG-1(config)#
line vty 0 4
login local

Для проверки доступности enable режима (#) после ввода этих команд выходим из всех режимов конфигурирования (командой exit в каждом из режимов или сочетанием клавиш Ctrl+Z), оказываемся в первоначальном режиме (обозначается знаком «>«) и пробуем вновь зайти в привилегированный режим (#). На запрос пароля вводим тот, что мы задали.

Если ничего не напутали, то видим примерно следующее:
SWR-DELTACONFIG-1 >enable
Password: *****
SWR-DELTACONFIG-1 #

Читайте также:  Biostar g41d3c xeon e5450

Проверку удаленного доступа можно осуществить , запустив из командной строки рабочей станции команду C:>telnet 192.168.1.1. Должно открыться окно приветствия и запрошен логин и пароль администратора.

После того, как убедитесь, что устройство доступно по протоколу Telnet (TCP порт 23) рекомендую настроить защищенный доступ по протоколу SSH (TCP порт 22). Подробные инструкции приведены в этой статье.

Шаг 4. Создание Vlan

Создаем Vlan для каждого из отделов и присваиваем им порядковые номера и названия.
SWR-DELTACONFIG-1(config)#
vlan 10
name NET_SALES
vlan 20
name NET_ACCOUNT
vlan 100
name NET_ADMIN
Сеть Vlan 1, которая будет использована для управления сетевым устройством, всегда присутствует на коммутаторе по умолчанию.
Проверить текущие настройки Vlan можно, выполнив команду show vlan:
SWR-DELTACONFIG-1# show vlan
VLAN Name Status Ports
—- ——————————— ——— ——————————-
1 default active Gi0/1, Gi0/2 , /. вырезано. /
10 NET_SALES active
20 NET_ACCOUNT active
100 NET_ADMIN active
/. вырезано. /

Убеждаемся, что все созданные нами сети присутствуют в списке.

Шаг 5. Привязка портов

Соотносим порты коммутатора созданным сетям Vlan. На коммутаторе в примере 24 порта Gigabit Ethernet.. Выделим первые 6 портов в сеть администраторов (Admin Vlan 100), 12 портов в сеть отдела продаж (Sales Vlan 10) и 6 портов в сеть для бухгалтерии (Account Vlan 20). На каждом интерфейсе коммутатора для удобства дальнейшего администрирования добавим примечания командой description. Это обычное текстовое поле, которое никак не влияет на другие настройки.
SWR-DELTACONFIG-1(config)#
interface range gi 0/1 – 6
switchport access vlan 100
description NET_ADMIN
interface range gi 0/7 – 18
switchport access vlan 10
description NET_SALES
interface range gi 0/19 – 24
switchport access vlan 20
description NET_ACCOUNT
После этого рядом с каждым Vlan в выводе команды sh vlan будут указаны принадлежащие ему порты

SWR-DELTACONFIG-1# show vlan
VLAN Name Status Ports
1 default active
10 NET_SALES active Gi0/7, Gi0/8, Gi0/9, Gi0/10, Gi0/11, Gi0/12, Gi0/13, Gi0/14,
Gi0/15, Gi0/16, Gi0/17, Gi0/18
20 NET_ACCOUNT active Gi0/19, Gi0/20, Gi0/21, Gi0/22, Gi0/23, Gi0/24
100 NET_ADMIN active Gi0/1, Gi0/2, Gi0/3, Gi0/4, Gi0/5, Gi0/6
/…вырезано. /
Важно!
Введенными командами мы разделили один физический коммутатор на 4 логических (Vlan 1, Vlan 10, Vlan 20 и Vlan 100). Сразу после этого взаимодействие будет осуществляться только(!) между портами, принадлежащими одному и тому же Vlan.

Важно!
На данный момент рабочие станции, подключенные в порты, принадлежащие разным Vlan, не смогут(!) взаимодействовать друг с другом даже если будет настроена адресация из одной сети.

Шаг 6. Маршрутизация

Для взаимодействия между сетями следует создать виртуальные интерфейсы 3его уровня для каждого Vlan.
SWR-DELTACONFIG-1 (config)#
inter vlan 10
ip address 192.168.10.1 255.255.255.0
description Sales
no shut
inter vlan 20
ip address 192.168.20.1 255.255.255.0
description Account
no shut
inter vlan 100
ip address 192.168.100.1 255.255.255.0
description Admins
no shut
SWR-DELTACONFIG-1 (config)# ip routing
Важно!
Ввод команды ip routing не является обязательным на большинстве современных версиях операционной системы IOS, так как маршрутизация пакетов включена по умолчанию.

Для сравнения: на коммутаторе 2ого уровня из указанной ранее инструкции возможно использование лишь одного интерфейса 3его уровня Vlan 1 и только для управления устройством. Именно поэтому в той статье для организации взаимодействия между сетями дополнительно используется маршрутизатор Cisco 2811.

В итоге все рабочие станции сети должны быть доступны друг другу после подключения их в соответствующие порты коммутатора. Проверять следует командой ping, выполнив ее из командной строки на рабочих станциях.

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
SWR-DELTACONFIG-1# write
Building configuration.
[OK]

пятница, 22 января 2016 г.

Настройка топологии сети организации Cisco L2 и L3 уровня + Mikrotik

Будем строить вот такую сеть на устройствах cisco

Описание сети:
VLAN1(default-IT) – 192.168.1.0/24
VLAN2(SHD) – 10.8.2.0/27
VLAN3(SERV) – 192.168.3.0/24
VLAN4(LAN) – 192.168.4.0/24
VLAN5(BUH) – 192.168.5.0/24
VLAN6(PHONE) – 192.168.6.0/24
VLAN7(CAMERS) – 192.168.7.0/24

Устройства:
Коммутаторы cisco с2960 L2-уровня – 3шт
Коммутатор cisco с3560 L2 и L3-уровня – 1шт
Все коммутаторы будут в VLAN1 и имеют сеть 192.168.1.0/24

Маршрутизатор любой(у меня Mikrotik RB750) – 1шт

Сервер Win2008 (DHCP) – для раздачи ip адресов
В каждом VLAN по 2 компьютера как оконечные устройства.

Для начала настроим коммутатор cisco L2 уровня sw1
По умолчанию все порты находятся в VLAN1 так что его создавать не будем.

  1. Подключаемся к консоли: telnet 192.168.1.1
  2. Вводим пароль
  3. sw1>enable (Переходим в привилегированный режим для ввода команд)
  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# vlan 2 (Создаем VLAN)
  3. sw(config-vlan)# name SHD (присваиваем имя этому VLAN2)
  4. sw(config-vlan)# exit (выход)
  5. Повторяем действия если необходимо добавить VLAN
  6. sw# show vlan brief (смотрим какие VLAN создали)
  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int fa0/3 (для одного порта Выбираем интерфейс)
  3. sw(config)# int fa0/3-4 (для нескольких сразу портов Выбираем интерфейс)
  4. sw(config-if)# switchport mode access (Указываем что этот порт будет для устройств)
  5. sw(config-if)# switchport access vlan 2 (назначаем этому порту VLAN2)
  6. sw(config-if)# no shutdown (включаем интерфейс)
  7. sw(config-if)# exit
  8. Повторяем действия для необходимых портов
  9. sw# show run (смотрим какие настройки устройства)
  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int gi0/1 (для одного порта Выбираем интерфейс)
  3. sw(config)# int gi0/1-2 (для нескольких сразу портов Выбираем интерфейс)
  4. sw(config-if)# switchport mode trunk (Указываем что этот порт будет для VLAN)
  5. sw(config-if)# switchport trank allowed vlan 2,3, (указываем какой VLAN будет проходить)
  6. sw(config-if)# no shutdown (включаем интерфейс)
  7. sw(config-if)# exit
  8. Повторяем действия для необходимых портов
  1. Так как данное устройство у нас L2, он не понимает что такое ip-адреса.
  2. Компьютеры подключенные к этим портам могут видеть друг друга в пределах своего заданного VLAN. Тоесть из VLAN1 я не попаду в VLAN2 и наоборот.
  3. Настроили гигабитный порт для передачи VLAN коммутатору sw2 -cisco 3560-L2L3.
Читайте также:  Число с 600 нулями

Добавляем к уже созданной нами сети на L2 коммутаторе(sw1), коммутатор(sw2) cisco-3560 L2L3

Настроим наше устройство 3560 L3(понимает ip адреса и делает маршрутизацию между VLAN)


1. Необходимо создать все VLAN которые будут описывать вашу топологию сети, так как данный коммутатор L3 будет маршрутизировать трафик между VLAN.

  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# vlan 4 (Создаем VLAN)
  3. sw(config-if)# name LAN (присваиваем имя этому VLAN2)
  4. sw(config-if)# exit (выход)
  5. Повторяем действия если необходимо добавить VLAN
  6. sw# show vlan brief (смотрим какие VLAN создали)

2. Определяем порты для подключения компьютеров.

  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int fa0/1 (для одного порта Выбираем интерфейс)
  3. sw(config)# int fa0/3-7 (для нескольких сразу портов Выбираем интерфейс)
  4. sw(config-if)# switchport mode access (Указываем что этот порт будет для устройств)
  5. sw(config-if)# switchport access vlan 9 (назначаем этому порту VLAN9)
  6. sw(config-if)# no shutdown (включаем интерфейс)
  7. sw(config-if)# exit
  8. Повторяем действия для необходимых портов
  9. sw# show run (смотрим какие настройки устройства)
  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int gi0/1 (для одного порта Выбираем интерфейс)
  3. sw(config)# int gi0/1-2 (для нескольких сразу портов Выбираем интерфейс)
  4. Так как мы настраиваем L3 нам необходимо перебрасывать из физ.порта в виртуальный порт ip-адреса и наоборот (инкапсуляция)
  5. sw(config-if)# switchport trunk encapsulation dot1q (Указываем инкапсуляцию)
  6. sw(config-if)# switchport mode trunk (Указываем что этот порт будет для VLAN)
  7. sw(config-if)# switchport trank allowed vlan 1-7, (указываем какой VLAN будет проходить)
  8. sw(config-if)# no shutdown (включаем интерфейс)
  9. sw(config-if)# exit
  10. Повторяем действия для необходимых портов

4. Переводим маршрутизатор в режим L3

  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# ip routing (включаем маршрутизацию)

5. Так как наш коммутатор L3 уровня, вешаем ip адреса на VLAN на порты для маршрутизации трафика.
Для межсетевого взаимодействия VLAN (чтобы можно было попасть из VLAN2 в VLAN3 и т.д)

Задаем всем виртуальным интерфейсам VLAN, ip адреса

  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int vlan 2 (на VLAN2 вешаем ip адрес)
  3. sw(config)# ip address 10.8.2.1 255.255.255.224 (этот адрес будет шлюзом для данной подсети)
  4. sw(config-if)# no shutdown (включаем интерфейс)
  5. sw(config-if)# exit
  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int vlan 3 (на VLAN3 вешаем ip адрес)
  3. sw(config)# ip address 192.168.3.1 255.255.255.0 (этот адрес будет шлюзом для данной подсети)
  4. sw(config-if)# no shutdown (включаем интерфейс)
  5. sw(config-if)# exit
  6. Повторяем действия для необходимых интерфейсов
  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# int vlan 9 (на VLAN9 вешаем ip адрес)
  3. sw(config)# ip address 192.168.9.2 255.255.255.0 (этот адрес будет шлюзом для данной подсети)
  4. sw(config-if)# no shutdown (включаем интерфейс)
  5. sw(config-if)# exit
  6. Повторяем действия для необходимых интерфейсов

6. Для выхода во внешнюю сеть(интернет) через наш маршрутизатор Mikrotik, необходимо прописать маршрут неизвестных запросов(внутренней сети) во внешнюю сеть. Для этого пропишем маршрут по умолчанию, т.к наш роутер один для выхода в интернет.

  1. sw# conf-t (переходим в режим настройки)
  2. sw(config)# ip route 0.0.0.0 0.0.0.0 192.168.9.1 (все внутренние неизвестные сети отправляем через маршрутизатор с ip адресом 192.168.9.1 )
  3. sw(config-if)# exit
Комментировать
3 065 просмотров
Комментариев нет, будьте первым кто его оставит

Это интересно
Adblock
detector